zoned/parse
getZonedOffset: Extract the UTC offset from an ISO 8601 zoned datetime string.getZonedOffsetAs: Read a zoned value’s UTC offset as a number, in the given unit.parseDateFromZoned: Extract the plain date portion from an ISO 8601 zoned datetime string.parseDateTimeFromZoned: Parse a zoned datetime and return the plain local datetime portion as an ISO plain datetime string.parseDayFromZoned: Return the day (1-31) from a zoned datetime string.parseDayOfWeekFromZoned: Return the day of the week (1-7, Monday-Sunday) from a zoned datetime string.parseHourFromZoned: Return the hour (0-23) from a zoned datetime string.parseMicrosecondFromZoned: Return the microsecond (0-999) from a zoned datetime string.parseMillisecondFromZoned: Return the millisecond (0-999) from a zoned datetime string.parseMinuteFromZoned: Return the minute (0-59) from a zoned datetime string.parseMonthFromZoned: Return the month (1-12) from a zoned datetime string.parseNanosecondFromZoned: Return the nanosecond (0-999) from a zoned datetime string.parseRfc2822: Parse an RFC 5322 (RFC 2822) date-time string — the fixed grammar emailDate:headers use — into a zoned ISO 8601 datetime string.parseRfc3339: Parse a strict RFC 3339 datetime string into a zoned ISO 8601 datetime string.parseSecondFromZoned: Return the second (0-59) from a zoned datetime string.parseTimeFromZoned: Extract the plain time portion from an ISO 8601 zoned datetime string.parseTimeZoneFromZoned: Extract the IANA timeZone identifier from an ISO 8601 zoned datetime string.parseUnitFromZoned: Return the requested unit value from an ISO 8601 zoned datetime string.parseWeekFromZoned: Return the week of the year for a given ISO 8601 zoned datetime string.parseYearFromZoned: Return the year for a given ISO 8601 zoned datetime string.
ZonedOffsetUnit: Unit a zoned value’s UTC offset can be read as viagetZonedOffsetAs.ZonedParseUnit: Units supported byparseUnitFromZonedwhen extracting a value from a zoned ISO string.